Posted by : Ham JavaNet Kamis, 18 April 2013


Mikrotik OS 5.7 dan Squid 2.7 Stable9

Disini maksudnya adalah apabila ada objek yang HIT dari cache proxy maka tidak terlimit oleh manajemen limit bandwidth yang kita buat baik di simple queue/queue tree. karena klo tetap terlimit ya percuma dong ente bikin squid proxy.
Sebenernya ada beberapa cara, tapi berikut yang ane gunakan dan terbukti efektif :

Pertama, pastikan ada baris perintah ini di squid.conf anda :

Code:
zph_mode tos
zph_local 48
zph_sibling 0
zph_parent 0
zph_option 136

Lalu buat Mangle baru di mikrotik anda, pastikan mangle ini posisinya diatas Mangle untuk manajemen bandwidth anda :

Code:
/ip firewall mangle add chain=postrouting dscp=12 action=mark-packet new-packet-mark=Proxy-DSCP passthrough=no

edit :
gunakan opsi mangle ini jika yang diatas tidak jalan (pilih salah satu saja)
Code:
/ip firewall mangle add chain=forward dscp=12 action=mark-packet new-packet-mark=Proxy-DSCP passthrough=no

Lalu buat rule queues, contoh disini adalah menggunakan queue tree :

Code:
/queue tree add name="Proxy HIT" parent=global-out packet-mark=Proxy-DSCP \
limit-at=0 queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

untuk simple queue silahkan sesuaikan saja, yang penting adalah penggunaan packet mark=Proxy-DSCP

Permasalahan akan muncul klo ada Dynamic Queue di simple queue seperti penggunaan login hotspot gateway mikrotik.
berikut penyelesaiannya ada di index Page 1 yaitu : Prioritas Proxy Hit diatas Dynamic Queue


Bagi pengguna hotspot mikrotik yang selama ini di puyengkan dengan munculnya queue dynamic di simple queue yang juga melimit proxy hit sehingga proxy hit jadi tidak maksimal untuk user hotspot. Dimana dynamic queue ini selalu muncul pada urutan queue paling atas sehingga akan di eksekusi pertama. semoga script dibawah ini bisa membantu rekan2 sekalian :

prinsip :
script ini bekerja dengan memonitor prioritas pada queue, sehingga berikan prioritas queue 1 pada proxy hit.

paste script berikut pada user profiles pada bagian on-login di IP>HOTSPOT>USER PROFILES
on login script :

Code:
:foreach n in=[/queue simple find priority=1] do={ /queue simple move $n [:pick [/queue simple find] 0] }

Trik untuk yang menggunkan user manager :
  • Buat user profiles sesuai dengan limitation pada user manager (IP>hotspot>user profiles)
  • Masukkan nama user profiles yang di buat tadi ke group name yang ada di limitation user manager bagian constraints
  • Buat profile user manager dengan limitation yang udah diberi grup barusan,

harusnya setiap ada user dari usermanager maupun user hotspot login otomatis dynamic queue-nya akan tergeser menjadi dibawah queue hit proxy.

Silahkan dicoba, jika ada yang salah ane mohon maaf karena juga hasil dari copas Ini sumbernya.

Mohon bagi yang sudah master dalam hal queue dan per-mikrotikan dibenarkan kalau ada yang salah, sukur2 jika mau menyempurnakan .

Description: [TUTORIAL] BYPASS HIT PROXY
Rating: 4.5
Reviewer: Ham JavaNet
ItemReviewed: [TUTORIAL] BYPASS HIT PROXY

Leave a Reply

Monggo Tinggalkan Jejak Kaks :)

Subscribe to Posts | Subscribe to Comments

Welcome to My Blog

Popular Post

Labels

Arsip Blog

Followers

- Copyright © 2013 shad0w-share | Designed by Johanes Djogan -